An existing connection was forcibly closed by the remote host. (10054)

Nathaniel

Member
Hi

Running Bticoin 18.1 with Electrum Personal Server.

I have "An existing connection was forcibly closed by the remote host. (10054)" in the debug file. Not sure what this means are how best to fix.

---------snip---------
2019-08-22T23:46:35Z UpdateTip: new best=0000000000000000000d12e53fae86f4042254cfac02c56d250ceb0e4708c86e height=591298 version=0x20800000 log2_work=90.994278 tx=447697552 date='2019-08-22T23:45:56Z' progress=1.000000 cache=94.5MiB(716742txo) warning='45 of last 100 blocks have unexpected version.'
2019-08-22T23:46:50Z socket recv error An existing connection was forcibly closed by the remote host. (10054)
2019-08-22T23:51:08Z UpdateTip: new best=000000000000000000182c582a21f660d07f4fd3ce435aefc5bf4081ca243102 height=591299 version=0x20000000 log2_work=90.994304 tx=447699499 date='2019-08-22T23:51:34Z' progress=1.000000 cache=94.7MiB(718338txo) warning='45 of last 100 blocks have unexpected version.'
2019-08-22T23:54:42Z UpdateTip: new best=000000000000000000164e955482234e50a5d01425f6ad421e7c254f54a990b9 height=591300 version=0x20000000 log2_work=90.994329 tx=447700103 date='2019-08-22T23:54:23Z' progress=1.000000 cache=94.8MiB(719352txo) warning='44 of last 100 blocks have unexpected version.'
------------end snip---------

Any help much appreciated. Cheers
 

Jesus

Member
Command line error when input -reindex or -reindex-chainsate unless I've got the command wrong?
You might do wrong here you can do -reindex if you open command prompt under bitcoin core folder where bitcoin-qt.exe installed.

Or you can do this below.
Find the folder of your bitcoin core wallet and right-click the bitcoin-qt.exe shortcut then click properties under target field add the reindex at the end.
Sample this image:


Then replace the -rescan to -reindex

It should be like this:
Code:
"C:\Program Files (x86)\Bitcoin\bitcoin-qt.exe" -reindex

or you can directly use the repair wallet under the core wallet then Rebuild index:





It seems that you solved the problem by using "Using chris-belcher/Electrum Personal Server" ? Am I right?
 

Maxwell

Member
socket recv error An existing connection was forcibly closed by the remote host. (10054)
There seems to be a problem with your current connection to a peer that's why you've received that error.
Are there any issues with your ISP or are you using any IP-changing setting/software?

Are you having trouble syncing or connecting to other nodes?
Your log looks fine to me as it continued to sync.

Additionally:
warning='44 of last 100 blocks have unexpected version.'
This is quite common for newly updated nodes with blocks verified by the older version.
 

Ivan

Member
Actually,
1. OP uses newest version (i think OP simply forget to add "0.")
2. The warning actually showed because miners/pools who use ASICBOOST. See https://bitcoin.stackexchange.com/a/85779
[1]
Smiley
Yes it's pretty obvious that he's using the latest version 0.18.1 (Aug 9).

[2] Actually, I missed the timestamps that he's almost at the latest height (so those were definitely "ASIC boost" blocks)
but there are few block-version-related issues that will result with that error... old issues.

BTW, that linked "error msg" was removed in 0.18.0. (https://github.com/bitcoin/bitcoin/pull/15471)
 

Stone

Member
Thanks for the advice which I've tried but didn't resolve the issue. Restored a backup and thought I'd cracked it but then alas no.

Coming to the conclusion I'll start it from scratch. It's a dedicated laptop with high bandwidth BB so won't take to long.

Hopefully I won't be back too soon
Wink


Learned a fair a bit from this thread.


Cheers
 

Kingston

Member
WAIT!!!

It looks normal to me... It's still receiving blocks and still has active connections? It just means that the remote host has shutdown or has stopped connecting to you (it might have reached it's maximum number of connections or soemthing). I'm not sure what the error is precicely but I always get it every couple of blocks and everything seems to work normally... It still broadcasts it's blocks and still keeps downloading so I don't think it's an error.

Code:
2019-06-04T16:49:26Z UpdateTip: new best=00000000000000000546714de9f29dcea0c433269e74144ef5bfce7cff649f4b height=344394 version=0x00000002 log2_work=82.27758 tx=60206998 date='2015-02-20T14:02:04Z' progress=0.144042 cache=772.9MiB(4345707txo)
2019-06-04T16:49:26Z UpdateTip: new best=00000000000000000e956d9ebdef88922d3cbb8df62822cc58719bce227b292a height=344395 version=0x00000002 log2_work=82.277627 tx=60208151 date='2015-02-20T14:14:27Z' progress=0.144045 cache=772.9MiB(4345552txo)
2019-06-04T16:49:26Z socket recv error An existing connection was forcibly closed by the remote host. (10054)
2019-06-04T16:49:27Z UpdateTip: new best=000000000000000016038b3ec9076d16a824a4a6e4a6b944d80d3bd17ce915f3 height=344396 version=0x00000002 log2_work=82.277674 tx=60209100 date='2015-02-20T14:25:59Z' progress=0.144047 cache=772.8MiB(4344931txo)
2019-06-04T16:49:27Z UpdateTip: new best=000000000000000014a0c54b037eabadde70e6e7f76fbc84d6d90dfd177eda50 height=344397 version=0x00000002 log2_work=82.277721 tx=60209495 date='2015-02-20T14:45:50Z' progress=0.144048 cache=772.9MiB(4345110txo)

I'm getting it on both windows and linux so it doesn't seem to be a problem to me.
 
Top